メインコンテンツへスキップ
  • レポートデータ(SPICE)量の確認方法と削除方法SPICEデータは、10GBまで無料でお使いいただけます。SPICEデータ容量確認後、必要に応じて、SPICEデータを減らすことができます。レポートデータ(SPICE)量の確認方法レポートデータ(SPICE)量の削除方法レポートデータ(SPICE)量の確認方法確認方法は、次のとおりです。当月のレポートデータ(SPICE)を確認する1グラフごとに使用されているレポートデータ(SPICE)をQuickSight画面で確認する当月のレポートデータ(SPICE)を確認する使用中のSPICE総データ容量を確認することができます。SMP管理画面より、利用状況画面([設定][利用状況])に遷移します「当月のレポートデータ(SPICE)の利用量(GB)」の当月を確認します1グラフごとに使用されているレポートデータ(SPICE)をQuickSight画面で確認するグラフの作成時と編集時に確認方法が異なります。グラフの作成時SMP管理画面より、グラフ画面([レポート][グラフ])に遷移します[QuickSightから新規登録]ボタンをクリックしQuickSight画面のデータセット画面に遷移します[新しいデータセット]ボタンをクリックします確認したいデータソースをクリックし、[データセットの作成]ボタンをクリックします「推定テーブルサイズ」項目に表示されているデータ量を確認しますグラフの編集時SMP管理画面より、グラフ画面([レポート][グラフ])に遷移します[QuickSightから新規登録]ボタンをクリックしQuickSight画面のデータセット画面に遷移しますQuickSight画面のデータセット画面より、確認したいデータセットをクリックします「SPICE」項目に表示されているデータ量を確認しますレポートデータ(SPICE)量の削除方法削除方法は、次のとおりです。利用していないデータセットを削除する利用中のデータセット内にある不要なフィールドを除外する利用していないグラフをSMP管理画面から削除する利用していないデータセットを削除するSMP管理画面より、グラフ画面([レポート][グラフ])に遷移します[QuickSightから新規登録]ボタンをクリックしQuickSight画面のデータセット画面に遷移します削除したいデータセットのメニュー[・・・]をクリックしますプルダウン中の[削除]をクリックしますデータセットの削除の確認画面内の情報を十分に確認し、[削除]ボタンをクリックします注意SMP管理画面で作成されたデータセットやダッシュボードは、SMP管理画面から削除することができます。ただし、QuickSight画面から作成されたものはSMP管理画面からは削除することができません。「利用していないデータセットを削除する」の手順に従って削除してください。補足データセットの削除同様に、分析とダッシュボードも古いものがないかを確認してください。削除方法は、データセットの削除方法と同じ手順です。利用中のデータセット内にある不要なフィールドを除外するSMP管理画面より、グラフ画面([レポート][グラフ])に遷移します[QuickSightから新規登録]ボタンをクリックしQuickSight画面のデータセット画面に遷移します[データセットの編集]ボタンをクリックします画面左側にある「フォーカス」より、不要なフィールドを除外します不要なフィールドのメニュー[・・・]をクリックします不要なフィールドを複数選択します一括で除外することができます。[フィールドを除外]リンクをクリック除外したフィールドが「除外されたフィールド」に移動していることを確認します[公開して視覚化]ボタンをクリックして、データセットの変更を完了させます分析を作成しますダッシュボードを作成しますSMPグラフをダッシュボードに表示させます注意データセットのフィールドを変更すると、分析とダッシュボードも新しく作成しなおさないとデータは反映されません。古いデータセットや分析、ダッシュボードは、削除してSIPCE量の削減を実施してください。利用していないグラフをSMP管理画面から削除するグラフを削除するをご参照ください。
    https://smpdoc.shanon.co.jp/ja/report/appendix/chapter002/

    レポートデータ(SPICE)量の確認方法と削除方法

  • FAQ権限に関するFAQデータ量に関するFAQグラフデータに関するFAQQuickSightに関するFAQ権限に関するFAQ1.ダッシュボードが表示されませんレポート機能を利用するにあたって必要となる設定があります。以下の設定が完了しているかご確認ください。「システム設定で必要な設定を行う」「ロール設定で権限を付与する」「管理者ごとにレポート利用の権限を付与する」また、レポート機能有効化直後の場合は、データ取得に時間がかかる場合があるので、しばらくたってから再度ご確認をお願いします。データ量に関するFAQ1.使用しているデータ容量(SPICE)はどこで確認することができますか?SMP管理画面のグラフ画面([レポート]→[グラフ])で、使用しているデータ容量の合計を確認することができます。各グラフが使用しているデータ容量は、QuickSight上で確認できます。また、「レポートデータ(SPICE)量の確認方法」ページもあわせてご確認ください。2.グラフが使用しているデータ容量(SPICE)はどのよう計算されていますか?グラフが使用しているデータ容量は、QuickSightのデータセットの容量となっており、グラフの元データの容量となります。3.データ容量(SPICE)を削減するにはどのようにしたらいいですか?詳細は、「レポートデータ(SPICE)量の削除方法」ページをご確認ください。4.データ容量(SPICE)の反映はいつされますか?レポート機能が内部的にデータセットを作成・更新した後に、非同期処理でSPICE容量を取得します。このため、実際のデータセット(SMPのレポートグラフ一覧に表示されるグラフ)の作成・更新から遅れてSPICE容量の値が更新され、画面に反映されます。5.事前にデータ容量(SPICE)は見ることはできますか?はい、できます。グラフデータに関するFAQ1.ダッシュボードのデータはどれくらいの頻度で更新されますか?ダッシュボードのグラフはリアルタイムのデータではなくキャッシュされたデータにより表示されます。キャッシュデータは、システムによる定期的な更新か、手動での更新により最新の状態となります。システムによる定期的な更新については「データソースの更新頻度について」ページをご確認ください。一緒に「データソース更新時におけるエラーコード」についてもご確認ください。2.データインポートでエラーが発生しましたがどうしたらいいですか?エラーコードの詳細は、AmazonQuickSoghtユーザーガイドより「データインポート中のエラーコード」ページをご確認ください。データインポートでエラーコード「INGESTION_SUPERSEDED」が発生しましたがどうしたらいいですか?データセット編集画面の「今すぐ更新」でSPICEのREFRESHを試行した場合、それより前に実行されて完了していないREFRESHが強制停止された場合に発生します。但し、一意に原因が決まるエラーではないため、発生前後のログを詳細に確認調査する必要があります。シャノンサポートまでお問合せください。4.データインポート時にデータが一部スキップされてしまいました。QuickSightのフィールドデータ型と値に不整合が起きています。フィールドデータ型を確認し、値に対して適切なデータ型を設定変更してからインポートしてください。変更方法は、AmazonQuickSightのユーザーガイド「フィールドのデータ型の変更」をご確認ください。基本項目設定のデータ型とQuickSightのデータ型が異なる場合、QuickSightのデータ型が優先される為、SMP基本項目設定のデータ型をQuickSightのデータ型に変更する必要があります。5.QuickSightでグラフを作成する簡単な例ってありますか?はい、あります。詳細は、「チュートリアル」ページをご確認ください。QuickSightに関するFAQ1.QuickSight画面のセッションタイムアウト時間はどれくらいですか?QuickSightの仕様に準じます。現時点では仕様として公開されていません。2.QuickSightでデータダウンロードする場合の行数制限ってありますか?はい、あります。Quicksightで作成されたグラフのビジュアルがテーブルチャート(ピボットテーブル、テーブル)なのか、テーブルチャート以外なのかによって異なります。QuickSightの仕様に準拠しますので、詳細は、AmazonQuickSightユーザーガイドより次のページをご確認ください。ビジュアルからのデータのエクスポートビジュアルの表示制限
    https://smpdoc.shanon.co.jp/ja/report/faq/

    FAQ

  • 制限事項制限事項について説明します。機能に関する制限権限に関する制限動作環境に関する制限アカウントについて機能に関する制限ダッシュボードに表示されるデータをダウンロードした際は、ダウンロードの通知や履歴は取得されませんデータソースの種別をCSVファイルにした場合、アップロードするCSVファイルの文字コードはUTF-8である必要がありますダッシュボードテンプレート、グラフテンプレートは、随時アップデートされることがあります。テンプレートをもとにダッシュボードやグラフを追加した場合、アップデートにより以前と異なった内容となることがありますSMPのバージョンアップによりデータソースとして利用しているデータが廃止された場合、従来表示していたグラフが利用できなくなることがありますQuickSight上で作成された、データセット・分析について、グラフ一覧に表示されていないもの(ダッシュボードとして公開されていないもの)については、定期的にデータ管理として削除されます。継続的にQuickSightで編集を可能にしたい場合、作成したデータセット・分析はダッシュボードとして公開し、グラフ一覧に表示される状態にしてください1つのダッシュボードに表示できるグラフ数は最大15個ですデータソースの上限行数はSPICEの上限が適用されますQuickSightのデータセット編集画面において、選択可能なデータセットに表示されるフィールド名はSMPのデフォルトの項目名称が使用され、[リード]→[基本項目設定]やメッセージ設定で行った変更は反映されません。グラフに表示されるフィールドの名前は「フィールドの変更」で行うことができますQuickSightの共有フォルダは利用することができませんQuickSightのデータセットにおいて、SagaMakerによるオーグメント・ファイルのアップロードは利用することができません。レポート機能におけるQuickSightのセッションタイムアウトは、QuickSightの仕様に準拠します。QuickSightのデータダウンロードにおける行数制限は、QuickSightの仕様に準拠します。詳細は、FAQページの「グラフデータに関するFAQ」ページをご確認ください。権限に関する制限代理ログインではレポート機能は利用できません動作環境に関する制限IE11ではレポート機能は利用できませんレポート機能は以下の表示設定に最適化して表示していますWebブラウザの表示倍率100%Windowsのテキストサイズ100%アカウントについてレポート機能を有効化した際に無償で提供されるアカウントは次の通りです。種類無償利用枠作成者ユーザ1ユーザ閲覧者ユーザ10ユーザSPICE使用量10GBまで注意上の数を超えた利用は有償となります。アカウント数を増やしたい場合は、担当営業もしくはカスタマーサポートへご連絡ください。
    https://smpdoc.shanon.co.jp/ja/report/limitation/

    補足資料

  • チュートリアルQuickSightを使ってグラフを作成し、ダッシュボードとして公開することができるようになることを目的としています。また、ダッシュボードを活用して、どのようなものを作成することができるか、いくつか事例をもとに紹介します。事例①「購買フェーズ推移ダッシュボード」事例②「特定リードにおける購買フェーズ推移ダッシュボード」事例③「開封率週間ダッシュボード」事例④「クリック率週間ダッシュボード」事例⑤「アノニマス比率を表示するダッシュボード」注意2022/08時点の情報で作成されています。QuickSightのアップデートによって仕様が変更される場合があります。最新の情報は、「AmazonQuickSightユーザーガイド」をご確認ください
    https://smpdoc.shanon.co.jp/ja/report/custom/chapter003/

    チュートリアル

  • データソースの結合データソースの結合は、データベースの結合に関する基礎的な知識があるユーザを対象にしています。。QuickSightでは複数のデータソースを結合したデータセットを作成することができます。データソースの結合の種類についてInnerJOINLeftJOINRightJOINFullJOINデータソースの結合の種類についてデータソース間の結合方法は、4種類あります。次をご確認ください。注意結合の条件を間違えると、意図せぬ量のデータが生成される場合があります。データソースは保存した時点で課金の対象になりますので、少量のデータで事前に検証されることをお勧めいたします。InnerJOIN両方のテーブルの一致する値を持つレコードになります。参考:.事例②「特定リードにおける購買フェーズ推移ダッシュボード」.事例⑤「アノニマス比率を表示するダッシュボード」LeftJOIN左側のテーブルからすべてのレコードを返し、右側のテーブルから一致するデータを結合します。参考:.事例④「クリック率週間ダッシュボード」」RightJOIN右側のテーブルからすべてのレコードを返し、左側のテーブルから一致するデータを結合します。FullJOIN両方のテーブルからすべてのレコードを返し、一致する行には値を表示して、一致しない行にはnullを表示します。
    https://smpdoc.shanon.co.jp/ja/report/custom/chapter002/

    データソースの結合

  • QuickSightについてシステム構成(グラフのビジュアル化)システム構成(QuickSightが使用するデータ)QuickSightの主な機能データソースデータセット分析ダッシュボードシステム構成(グラフのビジュアル化)QuickSightは、AmazonWebServices社のクラウド型のBIサービスで、グラフやダッシュボードの作成、ビジュアル化を提供します。レポート機能のダッシュボードに表示されるグラフは、QuickSightでビジュアル化されたグラフを利用しています。システム構成(QuickSightが使用するデータ)SMPの各種データやデータソースでアップロードしたCSVファイルは、はじめにAmazonS3に保存されます。次に、QuickSightが内部で使用しているデータベース(SPICE)へ自動でインポート(コピー)されます。このデータを使用してQuickSightでグラフやダッシュボードを作成し、集計・分析できるようになります。QuickSightの主な機能SMPのレポート機能で利用するQuickSightの機能には、主に以下のものがあります。機能説明データソースデータソースはQuickSightがアクセスするデータストアの設定です。レポート機能ではデータストアにAmazonS3のみ使用しています。詳細は「データソース」をご参照ください。データセット「データソース」から閲覧するための一部を切り出し、特定のテーブルの指定や見やすいフィールド名などの設定を定義したものです。この定義が保存されていることで、そのデータに基づく「分析」を作成するたびにデータを再度準備する必要がありません。詳細は「データセット」をご確認ください。分析データセットを様々なグラフで可視化したグラフのセットです。「分析」では複数のデータセットを使用できますが、グラフごとに使用できるのは1つのデータセットのみです。詳細は「分析」をご確認ください。ダッシュボード実際に閲覧する人がデータ分析するための、「分析」をリードオンリーで提供するものです。※QuickSightで作成した1つのダッシュボードがSMPの1つのグラフに該当します詳細は「ダッシュボード」をご確認ください。データソースデータソース一覧は、データセットを作成画面の既存データソースから(データセット画面の「新しいデータセット」ボタン)、確認することができます。SMPのグラフ画面([レポート][グラフ])より、[QuickSightから新規登録]ボタンをクリックしQuickSight画面に遷移します遷移直後は、分析画面が表示されます。左メニューの「データセット」より、データセット一覧画面に遷移します[新しいデータセット]ボタンをクリックしますデータソース一覧画面に遷移します。データセットデータセット一覧登録済みのデータセットが表示されます。SMPのグラフ画面([レポート][グラフ])より、[QuickSightから新規登録]ボタンをクリックしQuickSight画面に遷移します左メニューの「データセット」をクリックしますデータセット一覧画面に遷移します。補足データセットのアイコンが2種類あり、それぞれは次のとおりです。・:複数のデータを結合して作ったデータセット・:単体のデータソースから作られたデータセットデータセット編集データセットの編集画面です。使用するフィールド、フィールドの名前、データ型などの設定、計算フィールドを利用したカスタムフィールドを追加できます。SMPのグラフ画面([レポート][グラフ])より、[QuickSightから新規登録]ボタンをクリックしQuickSight画面に遷移します左メニューの「データセット」より、データセットを選択します例:リードのデータソースを選択する場合[新しいデータセット]ボタンをクリックします「リード」のデータソースをクリックします[データセットの作成]ボタンをクリックします[データの編集/プレビュー]ボタンをクリックしますデータセットの編集画面に遷移します。補足データソースの各フィールド内のデータを確認するには、次の画像をご確認いただき、「テーブルのプレビューを表示」をクリックしていただけますと、データを確認することができます。「削除」をクリックするとデータソースを削除し、画面右側にある「データを追加」ボタンより追加することができます。分析分析の一覧登録済みの分析が表示されます。SMPのグラフ画面([レポート][グラフ])より、[QuickSightから新規登録]ボタンをクリックしQuickSight画面に遷移します遷移直後は、分析画面に遷移します。分析の編集分析の作成画面です。作成済みのデータセットを使って様々なチャートを作成することができます。SMPのグラフ画面([レポート][グラフ])より、[QuickSightから新規登録]ボタンをクリックしQuickSight画面に遷移します編集したい分析をクリックします分析の編集画面に遷移します。ダッシュボードダッシュボードの一覧登録済みのダッシュボードが表示されます。SMPのグラフ画面([レポート][グラフ])より、[QuickSightから新規登録]ボタンをクリックしQuickSight画面に遷移します左メニューの「ダッシュボード」をクリックしますダッシュボードの一覧画面に遷移します。ダッシュボードの閲覧登録済みのダッシュボードのビジュアライズしたグラフを確認することができます。SMPのグラフ画面([レポート][グラフ])より、[QuickSightから新規登録]ボタンをクリックしQuickSight画面に遷移します左メニューの「ダッシュボード」をクリックします閲覧したいダッシュボードをクリックします
    https://smpdoc.shanon.co.jp/ja/report/custom/chapter001/

    QuickSightについて

  • アカウントを管理するレポート機能の使用アカウント数を確認することができます。アカウントを管理するGoogleAnalyticsを連携するアカウントを管理する[レポート][アカウント]では、レポート機能の使用アカウント数を確認することができます。また、[設定][ユーザ設定]にてレポートアカウントを使用しているユーザを確認することができます。レポート作成者、レポート閲覧者の権限については「レポート機能の管理者権限について」ページをご確認ください。GoogleAnalyticsを連携するデータソースとしてGoogleAnalyticsを利用する場合、事前にGoogleAnalyticsとの連携設定を行う必要があります。[レポート][アカウント]に表示される「SigninwithGoogle」ボタンをクリックします。[SigninwithGoogle]ボタンをクリックすると、Googleアカウントの選択画面に遷移します。SMPと紐づけるGoogleアカウントを選択しクリックすると、以下の画面に遷移します。内容に問題がなければ[続行]ボタンをクリックします。以下の画面に遷移すればSMPとGoogleAnalyticsアカウントの紐づけが完了します。
    https://smpdoc.shanon.co.jp/ja/report/account/

    アカウントを管理する

  • データソースを管理するキャンペーンやリード、申込履歴、メール送信履歴のようなオブジェクトのデータのことをデータソースと呼び、[レポート][データソース]から作成済みのデータソースを確認することができます。作成済みのデータソースを確認するデータソースの種別についてレポート機能で提供するデータソースデータソース間の関連検索条件のデータソースを作成するCSVファイルからデータソースを作成するGoogleAnalyticsからデータソースを作成するデータソースの更新頻度について作成済みのデータソースを確認するデータソースの一覧には以下の項目が表示されます。項目名説明IDデータソースのIDを表示します。名前データソース名を表示します。種別データソースの種別を表示します。種別の詳細は、「データソースの種別について」をご確認ください。更新日時最後にデータソースが更新された日時を表示します。状況データソースの更新状況を表示します。・更新中:現在更新処理が行われている状態です。・成功:更新が完了している状態です。編集データソースの編集リンクを表示します。削除データソースの削除リンクを表示します。データソースの種別についてデータソースには以下の種類があります。種別説明システムによる自動更新標準キャンペーンやリードのようなシステムが提供するデータソースです。データソースの詳細は「レポート機能で提供するデータソース」をご確認ください。定期的に更新されます。検索条件リードの検索条件に該当するリードIDだけが含まれるデータソースです。設定方法は「検索条件のデータソースを作成する」をご確認ください。定期的に更新されます。CSVファイル管理者がCSVファイルを使って作成した固有のデータソースです。。設定方法は「CSVファイルからデータソースを作成する」をご確認ください。更新されません。アップロードしたCSVファイルの内容で固定されます。GoogleAnalytics連携設定を行ったGoogleAnalyticsのデータソースです。設定方法は「GoogleAnalyticsを連携する」をご確認ください。定期的に更新されますレポート機能で提供するデータソースレポート機能では以下のデータソースを提供しています。カテゴリデータソース名キャンペーンキャンペーンサブキャンペーンフローアンケートアンケート回答履歴アンケート回答資料、動画公開資料動画メールメールテンプレートメール送信トラッキング(アノニマス含む)トラッキング履歴トラッキングユーザーゴールゴールゴール達成状況リードリードリスト企業リード履歴申込サブキャンペーン申込来場活動履歴企業関連付けメール送信履歴クリックカウントトラッキングセッションユーザーアクセスログ動画視聴履歴ゴール履歴DM送信履歴SFA商談パイプラインステージデータソース間の関連データソース間は以下図のように関連付けられています。補足拡大図は「こちら」からご確認ください。検索条件のデータソースを作成する検索条件のデータソースを利用することで、グラフに表示するリードをその検索条件で絞り込むことができます。データソース画面([レポート][データソース])に遷移します。[新規登録]ボタンをクリックします。次を指定します。種別で「検索条件」作成したい検索条件を指定検索条件には、リード一覧から「全ユーザ使用可」で作成した検索条件を指定することができます。CSVファイルからデータソースを作成するCSVファイルのデータソースを利用することで、自身が持っているマスタデータをデータソースとして作成することができます。この機能を利用することで、SMPのデータと外部システムのデータを結合したグラフを作成することが可能となります。例えば、SMPとSFAを連携して利用している場合に、次のようなグラフを作成することができます。SMPに保存されているリード情報とSFAの商談情報を結合したグラフを作成SMPとウェブアナリティクスツールを連携して利用している際に流入経路ごとのコンバージョンのグラフを作成複数のデータソースを結合したグラフの作成方法は「チュートリアル」をご確認ください。補足ファイルのアップロードについては「ファイルのアップロード」ページをご確認ください。GoogleAnalyticsからデータソースを作成するGoogleAnalyticsのデータソースを利用することで、GoogleAnalyticsから取得したWebサイトのアクセス状況などのデータをデータソースとして作成することができます。この機能を利用することで、SMPのデータとGoogleAnalyticsのデータを結合したグラフを作成することが可能となります。GoogleAnalyticsのデータソースを作成する方法は、次のとおりです。データソース画面([レポート][データソース])に遷移します[新規登録]ボタンをクリックします。種別で「GoogleAnalytics」を選択します。作成したい「プロパティ」「ディメンション」「指標」「期間」を指定して登録します。補足「ディメンション」「指標」は複数個登録することができます。データソースの更新頻度についてダッシュボードのグラフはリアルタイムのデータではなくキャッシュされたデータにより表示されます。キャッシュデータは、システムによる定期的な更新、手動での更新により最新の状態となります。システムによる定期的な更新は、1日に数回行われますが、最長でも1日に1回は更新されます。手動での更新は、任意のタイミングで更新することができます。更新方法は次のとおりです。データソース一覧画面([レポート][データソース])のに遷移します[データソース更新]ボタンをクリックしますデータソースが更新された最終日時は、データソース一覧の「更新日時」で確認することができます。注意更新中にエラーとなる場合があります。エラーコードの詳細は、AmazonQuickSoghtユーザーガイドの「データインポート中のエラーコード」ページをご確認ください。また、合わせて、FAQページの更新中のエラーに関する記事についてもご確認ください。
    https://smpdoc.shanon.co.jp/ja/report/datasource/

    データソースを管理する

  • 利用開始までの手順レポート機能を利用するにあたって、はじめにいくつか設定が必要な流れがあります。レポート機能を有効化するシステム設定で必要な設定を行うロール設定で権限を付与する管理者ごとにレポート利用の権限を付与するレポート機能を有効化するレポート機能をご利用頂くためには、レポート機能の有効化が必要となります。有効化については、担当営業もしくはカスタマーサポートへご連絡ください。レポート機能の有効化はお申込みのご連絡を頂いてから最短1営業日必要となります。システム設定で必要な設定を行うシステム設定画面([設定][システム一覧])より、次のようになっていることを確認します。この設定を満たさない場合、レポート機能を利用することはできません。設定項目値管理画面JQueryバージョン3以上ロール設定で権限を付与するロール設定で必要な権限を付与し、管理者がアクセスできるよう設定します。URLパス権限の内容/bi2/dashboard/viewダッシュボードを表示する権限です/bi2/dashboard/sortダッシュボードプルダウンの並び順を変更する権限です/bi2/dashboard/addダッシュボードを新規追加する権限です/bi2/dashboard/editダッシュボードを編集する権限です/bi2/dashboard/deleteダッシュボードを削除する権限です/bi2/dashboard/graph_addダッシュボードへレポートを追加する権限です/bi2/dashboard/graph_deleteダッシュボードからレポートを削除する権限です/bi2/dashboard/graph_add_postグラフをダッシュボードへ追加する権限です/bi2/graph/listグラフ一覧を表示する権限です/bi2/graph/addグラフを追加する権限です/bi2/graph/editグラフを編集する権限です/bi2/graph/deleteグラフを削除する権限です/bi2/graph/popup_slistグラフをダッシュボードへ追加する権限です/bi2/graph/user_graph_syncQuickSightで作成したカスタムグラフをSMPへ同期する権限です/bi2/datasource/listデータソースの一覧を表示する権限です/bi2/datasource/addデータソースを新規登録する権限です/bi2/datasource/editデータソースを編集する権限です/bi2/datasource/deleteデータソースを削除する権限です/bi2/datasource/etlデータソースのデータの更新を実行する権限です/bi2/accountダッシュボードを利用している管理者アカウントを表示する権限です/bi2/datasource/ga_accessデータソースとしてGoogleAnalyticsを利用する権限です/bi2/ga_authGoogleAnalyticsと連携するための画面を表示する権限です/samlidp/authQuickSight利用時の認証機能です管理者ごとにレポート利用の権限を付与するダッシュボード機能が有効化された後、ダッシュボードを利用する管理者へ権限を付与します。権限付与は、管理者情報の編集機能([設定][ユーザー設定]より、権限を付与するユーザーの[編集])で行います。アカウント数を増やしたい場合は担当営業もしくはカスタマーサポートへご連絡ください。レポート利用ユーザの種別レポート機能の有効化時点では下記の権限数がSMPに付与されています。権限の種類説明作成者ユーザレポート機能を利用する管理者で、グラフやダッシュボードの作成、編集の権限を持つ管理者です。レポート作成者の権限については「レポート機能の管理者権限について」ページをご確認ください。閲覧者ユーザレポート機能を利用する管理者で、ダッシュボードやグラフの作成、編集ができない主にダッシュボードを参照するための管理者です。レポート閲覧者の権限については「レポート機能の管理者権限について」ページをご確認ください。レポート機能の有効化時点で提供されるアカウントについては「アカウントについて」ページをご確認ください。
    https://smpdoc.shanon.co.jp/ja/report/procedure/

    利用開始までの手順

  • 概要レポート機能についてレポート機能の構成についてレポート機能の仕組みについてレポート機能の管理者権限について用語レポート機能についてレポート機能には以下の4つの機能があります。機能説明ダッシュボードダッシュボードには、最大15個のグラフを表示することができます。可視化されたデータから属性やアクティビティを分析することができます。ダッシュボードの作成は、システムが用意したダッシュボードテンプレートを使用することができ、ニーズに応じて様々な種類のグラフを追加し、グラフのサイズや順序を変更することができます。機能の詳細は、「ダッシュボードを確認する」をご確認ください。グラフダッシュボードへ表示するためのグラフを管理することができます。システムが用意した標準グラフテンプレートを利用して容易にグラフを作成することができます。また、QuickSight機能を利用することでユーザグラフを作成することもできます。機能の詳細は、「グラフを管理する」をご確認ください。データソースレポート機能では高速にダッシュボードを表示するために、レポート機能に特化したデータを使用しています。データソースには、システムが提供している「標準」データソース、標準データソースをリードの検索条件で絞り込んだ「検索条件」データソース、ユーザーがCSV形式で取り込んだ「CSVファイル」データソース、GoogleAnalyticsのデータを用いた「GoogleAnalytics」データソースがあります。「検索条件」データソースを使用することにより、特定のリードでフィルタしたグラフを作成できるようになります。また、マスタデータなどのCSVファイルをアップすることでSMPのデータと結合したオリジナルのグラフを作成することができます。「GoogleAnalytics」データソースを使用することにより、SMPのデータとGoogleAnalyticsのデータを結合したグラフを作成することができます。「標準」、「検索条件」、「GoogleAnalytics」データソースは定期的なデータ更新が行われます。また、手動による即時データ更新を行うことができます。機能の詳細は、「データソースを管理する」をご確認ください。アカウントレポート機能を利用中の管理者情報を表示します。機能の詳細は、「アカウントを管理する」をご確認ください。レポート機能の構成についてレポート機能では、データの集計やグラフ表示にAmazonWebServices社のQuickSightサービスを使用しています。AmazonQuickSight(以降、QuickSight)についての詳細な情報は、こちらをご確認ください。レポート機能は主に以下図の要素で構成されています。レポート機能の各機能での仕組みについては、次の「レポート機能の仕組みについて」をご確認ください。レポート機能の仕組みについてレポート機能ではグラフやダッシュボードの作成、表示にQuickSightを利用しており、各機能では次のような仕組みで動作しています。ダッシュボードの表示グラフの作成、編集SMPデータのQuickSightへの同期レポート機能の管理者権限についてレポート機能を利用する管理者権限には「作成者ユーザ」と「閲覧者ユーザ」の2つがあります。それぞれの権限の違いは、次のとおりです。機能作成者ユーザ閲覧者ユーザダッシュボード機能◯◯グラフ機能◯◯QuickSightを使用したグラフの作成、編集◯×データソース機能◯◯アカウント機能◯◯用語本機能で使用する用語を以下にまとめます。用語説明レポートダッシュボード機能に代わる新しいレポート機能全体の総称ですデータソースキャンペーンやリードのようなSMPを構成する元の各データで、グラフで使用する元データをデータソースと呼びます。SMPが提供するデータの他に、外部のCSVファイルを取り込んだものやGoogleAnalyticsデータなどもあります。利用できるデータソースの種類は「レポート機能で提供するデータソース」をご確認ください。データセット1つまたは複数のデータソースを結合して作成したデータの集合です。グラフの元データになるもので、グラフごとに最適なデータセットを作成します。グラフデータセットのデータをビジュアル化したひとつのチャートで、棒グラフ、折れ線グラフ、円グラフのようなチャートがあります。利用できるグラフの種類は「グラフテンプレートについて」をご確認ください。ダッシュボード複数のグラフを一画面にまとめて閲覧できるようにしたものです。作成者ユーザレポート機能を利用する管理者で、グラフやダッシュボードの作成、編集の権限を持つ管理者です。レポート作成者の権限については「レポート機能の管理者権限について」をご確認ください。閲覧者ユーザレポート機能を利用する管理者で、ダッシュボードやグラフの作成、編集ができない主にダッシュボードを参照するための管理者です。レポート閲覧者の権限については「レポート機能の管理者権限について」をご確認ください。QuickSightQuickSightはAmazonWebServices社のクラウド型のBIサービスで、グラフやダッシュボードの作成、ビジュアル化を提供します。SPICEQuickSight上で使用するデータソースのデータを保管するためのQuickSight内部で使用される専用データベースです。
    https://smpdoc.shanon.co.jp/ja/report/summary/

    概要

  • QuickSightのセッションは、QuickSightを提供しているAWS(アマゾンウェブサービス)が管理しています。
    AWS(アマゾンウェブサービス)では現在、具体的なセッションタイムアウト値は公開しておりません。

    注意点

    • SMPの[システム設定]の[ログインセッション有効期間(管理者)]は、QuickSightのセッションとは関連していません。
    • QuickSightのセッションタイムアウト時間は変更することができません。

    関連コンテンツ

     

    QuickSightのセッションタイムアウトが知りたい

  • QuickSightからCSVダウンロードする際のデータの行数については、QuickSightで作成されたグラフのビジュアルタイプの種別によって上限値が異なります。
    以下に、ビジュアルタイプ別による制限を紹介します。

    20220810-163327.jpg

    図1:ビジュアルタイプ


    1.ビジュアルタイプ別の制限について

    ビジュアルタイプ:テーブルチャート(テーブル)の場合

    最大で100万行または 500 MBのデータ (いずれか最初に上限に達したほう) が上限値となります。
    ※上記を超える可能性がある場合は、フィルタ機能でデータ量を調整してCSVダウンロードを行ってください。

     

    ビジュアルタイプ:テーブルチャート(ピボットテーブル)の場合

    ピボットテーブルでは下と右へのスクロールがサポートされています。
    行に最大 20 のフィールド列に最大 20 のフィールドを追加でき、最大で50万行が上限値となります。

     

    テーブルチャート以外のビジュアルタイプの場合

    各ビジュアルタイプに適用される表示制限によって上限値が異なります。
    例えば、下記グラフにあるように、「ビジュアルタイプ:棒グラフ、水平」の場合は、Y軸の表示上限数は2500のため、CSVファイルでダウンロードできる最大値も2500行までとなります。

    ビジュアルタイプ 項目 行数制限
    棒グラフ、水平 Y 軸 2,500
    棒グラフ、垂直 X 軸 2,500
    コンボグラフ X 軸 2,500
    ヒートマップ 行 、列 100
    折れ線グラフ X 軸 10,000
    円グラフ グループ/色(スライスの数) 20
    ツリーマップ Group by (グループ化の条件)表示された正方形の数 100


    1万行以上のデータをQuickSightで一括でダウンロードしたい場合は、作成したグラフのビジュアルタイプを「テーブル」に変更することで、ダウンロードすることが可能となります。

     

    2.関連コンテンツ

    QuickSightからCSVダウンロードする際にデータの行数制限はありますか

  • 操作を行っている管理者のロール設定で、機能有効化の手順が不足しています。
    ロール設定で不足している権限の付与方法について説明します。

     

    1.権限エラーの内容について

    全キャンペーン(青い画面)>[レポート]>[グラフ]>[Quicksightから新規登録]のボタンを押すと以下画像のような権限エラーが表示される場合は、本ケースの事象に該当します。

    report.gif

    図1:エラー画像

    権限エラー
    申し訳ございませんが、お客様の権限ではこの機能へのアクセスが許されていません。
    前のページにお戻りください。
    この機能を使用したい場合は、システム管理者に申し出てください。


    2.エラーの原因について

    ロール設定において、「QuickSight利用時の認証機能」という項目が無効になっています。
    以下のロール設定をONにしてください。

    機能ID:1098  SAMLレスポンス /samlidp/auth

     

    3.解決方法について

    以下手順で今回原因となっているロール設定の項目を有効化してください。

    1. 全キャンペーン管理(青い画面)から、[設定]をクリックします。
      権限がない場合、[設定]が表示されない場合があります。
      その場合、[設定]が表示される管理者にて作業を行ってください。
    2. 管理者の一覧が表示されますので、ロール設定を変更したい管理者の[詳細]リンクをクリックしグループ名を控えます。
    3. 設定>[グループ設定]から、該当するグループの[詳細]を確認します。
      [役割一覧]に割り当てられているロールが確認できます。
    4. ロールの[詳細]リンクをクリックします。
    5. [編集]ボタンをクリックし、ブラウザの画面検索[/samlidp/auth]などで以下機能を検索します。
      機能ID:1098  SAMLレスポンス /samlidp/auth
    6. [/samlidp/auth]横のチェックボックスにチェックを入れ、[登録]ボタンをクリックします。

      CONTENTS_MANAGEMENT-1110.gif

      図2:ロール設定の手順

    補足

    上記ロール設定後、ロール設定を反映させるため、一度SMPをログアウトしていただき、変更したロールを利用する管理者で再ログインしてQuicksightから新規登録を行って下さい。

     

    4.関連コンテンツ

    レポート機能でグラフを新規登録しようとすると権限エラーが発生する

  • QuickSightの一部操作に機能制限を行っており、ご利用できない機能があります。
    QuickSightのデータセット作成画面上で「ファイルのアップロードにエラーが発生しました」というエラーが表示された場合の対処法を説明します。

    aaaaaaa.png

    図1:エラー画像:「ファイルのアップロードにエラーが発生しました」

     

    1.原因

    QuickSightのデータセット作成画面の、[データを追加]>[ファイルのアップロード]する機能は機能制限を行っておりご利用できない機能です。

    saisinn.png

    図2:ファイルのアップロード画面

     

    2.対策

    CSVファイルのインポートは、SMPの管理画面から行うことができます。
    追加したいデータセットがある場合は、SMP管理画面からデータソースをインポートしてください。

    1. 全キャンペーン(青色の画面)のレポート[データソース]をクリックします。
    2. データソースの一覧が表示されますので、右上の[新規登録]をクリックします。
    3. アップロード画面を開きましたら、[種別]を「CSVファイル」に選択します。

      iiii20220722.gif

      図3:CSVファイルをデータソースとして登録する

    4. 他の必須項目を埋め、ファイルを参照し[登録]をクリックします。

    注意点

    CSVの日付型をQuickSightでサポートされているデータ型に合わせてインポートする必要があります。
    CSVに日付データがある場合は、インポート時にCSV側でデータ型を以下形式に変更してください。
    詳細は、「QuickSightのデータセット編集で日付形式を変更したい」を確認してください。

    3.関連コンテンツ

    QuickSightのデータセット画面でCSVファイルがアップロードできない

  • CSVの日付型をQuickSightでサポートされているデータ型に合わせてインポートする必要があります。
    CSVに日付データがある場合は、インポート時にCSV側でデータ型を以下形式に変更してください。

    • 「YYYY‐MM‐DD hh:mm:ss」
    • 「YYYY/MM/DD hh:mm:ss」

     

     

    1.Quicksightで日付形式を変更する

    1. SMP管理画面 〉[レポート]タブ  〉[データソース]画面で 新規登録をクリックします
    2. インポートしたいCSVデータを登録します
    3. SMP管理画面 〉[レポート]タブ  〉[グラフ]画面で「QuickSightから新規登録ボタンをクリックしQuickSightへ遷移します
    4.  QuickSight画面〉[データセット] 〉「新しいデータセット」 をクリックします
    5. 該当のデータセットをクリックし [データセットの作成] 〉データの編集 /プレビューをクリックします
    6. データソース2行目のヘッダーにデータ型が表示されています。日付データは「文字列」でインポートされていますので「文字列」をクリックし、タイプを「日付」に変更することでデータ型を変更できます。
    7. 「日付形式の編集」画面の[検証]をクリックして、有効な日付形式であるかを確認することができます。
      ※赤字で「行が無効です」の表示になった場合や
       [更新]をクリックして「既知の日付形式は検出されませんでした」と表示された場合は、
       インポートした日付形式を修正してください。
       動画では日付形式が「2022年1月1日」のような形式となっているため更新ができないことがわかります。

    _______.gif

               図1.QuickSight(データセット画面)での日付形式の編集           

    注意点

    「2022年1月1日」のような日付形式はQuickSightサポートされていません。
    ・日付形式の編集で更新したときに「既知の日付型は検知されませんでした」というエラーが表示
     された場合は、日付データのデータ型を変更しCSVインポートしなおしてください。

     

    2.関連コンテンツ

    QuickSightのデータセット編集で日付形式を変更したい

  • SMPで作成したグラフはSMPの管理画面から、
    QuickSightで作成したグラフは、QuickSightの管理画面から削除が可能です。

     

    1.QuickSightから行う削除方法

    1. 全キャンペーン管理(青画面)>サイドメニュー:レポート>グラフをクリックします。
    2. 画面右上の「QuickSightから新規登録」ボタンをクリックします。
    3. QuickSightのページに移動したら、サイドメニュー:ダッシュボードをクリックします。
    4. 削除したいグラフの縦三点リーダー(︙)をクリック後>削除>Doneをクリックします。
    5. 全キャンペーン管理(青画面)>サイドメニュー:レポート>グラフ画面に戻り、削除状況を確認します。

    __03.gif

    図1:QuickSightから行う削除方法

     

    2.管理画面から行う削除方法

    1. 全キャンペーン管理画面(青画面)>サイドメニュー:レポート>グラフをクリックします。
    2. 該当のグラフの右側にある「削除」ボタンをクリックします。
    3. 確認画面に遷移し、問題がなければ「削除」ボタンをクリックします。
    4. 全キャンペーン管理(青画面)>サイドメニュー:レポート>グラフ画面に戻り、削除されていることを確認します。

    ______.gif

    図2:管理画面から行う削除方法

     

    注意点

    削除実行に時間がかかる場合に、対象のグラフがすぐに一覧画面から非表示にならない場合があります。非表示にならない場合は、1時間ほど時間を空けて削除確認を行ってください。

    3.関連コンテンツ

    レポート機能のグラフの削除方法について

  • データセット作成時に下記の3つの設定ボタン(図1)が画面上に表示されます。
    この記事では、各設定ボタンの利用用途と利用例について説明します。

    date.png
    図1:「データソースの詳細」

     

    目次

    1. 設定ボタンについて
    2. 「データ編集/プレビュー」の利用用途と利用例
    3. 「視覚化する」の利用用途と利用例
    4. 関連コンテンツ

    1.設定ボタンについて

    各設定ボタンの概要と利用可否をまとめた表です。
    機能名 概要 利用可否
    データ編集/プレビュー データを編集したりデータの詳細を確認することができます。
    視覚化する データソースやデータセットをグラフとして視覚化できます。
    SageMakerによるオーグメント AWSが提供している機械学習サービスです。
    (SMPでは利用できません。)
    不可

    2.「データ編集/プレビュー」の利用用途と利用例

    「データ編集/プレビュー」は、データソースの詳細を確認したり、データソースを追加し結合させることでデータセットを作成することができます。
    また、データソースをグラフとして視覚化させ確認することが可能です。

    「データ編集/プレビュー」ボタンには下記の手順で遷移できます。

    全キャンペーン管理画面(青い画面)サイドメニュー[レポート]内の[グラフ]>右上[QuickSightから新規登録]>右上[新しい分析]>左上[新しいデータセット]>任意のデータソースを選択し、[データセットの作成]

     

    【利用例】都道府県別のサイトアクセス数をグラフで視覚化したい場合

    例えば、都道府県別のサイトアクセス数をグラフで視覚化したい場合、
    「リード」データと「トラッキングデータ」の情報を結合(図2)させる必要があります。

    「データ編集/プレビュー」では、「リード」データと「トラッキング」データの情報を結合することが可能です。
    結合した後のグラフを視覚化する方法は、4関連コンテンツに記載されているマニュアルをご参照ください。

    datagif_1.gif
    図2:「データ編集/プレビューに遷移した場合」



    3.「視覚化する」の利用用途と利用例

    「視覚化する」を選択することで、作成したデータソース・セットを様々なグラフで表示させて確認することができます。

    「視覚化する」ボタンには下記の手順で遷移できます。

    全キャンペーン管理画面(青い画面)サイドメニュー[レポート]内の[グラフ]>右上[QuickSightから新規登録]>右上[新しい分析]>左上[新しいデータセット]>任意のデータソースを選択し、[視覚化する]

     

    【利用例】リードの会社名の数を確認したい場合

    リードの会社名の数を確認したい場合は、リードのデータソースを視覚化することで、
    会社名の数を確認するグラフを表示(図3)することが可能です。
    詳細な設定方法に関しましては、4関連コンテンツに記載されているマニュアルをご参照ください。

    data7.gif

    図3:「会社名を視覚化した場合」

     

    4.関連コンテンツ

    レポート機能の「データ編集/プレビュー」「SageMakerによるオーグメント」「視覚化する」の違い

  • レポート機能では、SMPを利用して蓄積したデータを分析するために
    標準でデータソースをご提供しています。
    レポート機能で提供しているデータソースについては以下マニュアルをご覧ください。

     

     

    データソースを組み合わせることで分析に必要なデータを作成することが可能です。
    そのためには、各データソース間のリレーション関係を把握することが必要となります。

     

     

    1.データソース間のリレーション関係

    データソース間のリレーション関係を把握したい場合は以下のチュートリアルをご覧ください。
    一部データソースの結合可能な項目がER図で記載してあります。

    記載してあるER図をご参考にしていただき、複数のデータソースをつなぎ合わせることで、
    一つのデータセットとしてレポート機能で利用することができます。

     

     

    2.データソースの結合例

    データソース同士を結合する際、どのように結合することができるのか
    結合例を以下のチュートリアルに記載してあります。


    【例1】流入経路毎に集客(申込)状況を可視化したい
    「キャンペーン 」「フロー 」「 申込」の結合例(P18)

    【例2】開封率のリードセグメント分析がしたい
    「リード 」「 メール送信履歴」の結合例(P19)

     

     

    3.関連コンテンツ

    レポート機能で使用するデータソース間の結合キーを知りたい

  • グラフ内のテキスト型項目のデータ要素に対して並べ替えを行うと、
    データの数ではなく、文字コードに対しての並び順となってしまいます。

    このようなテキスト型データ要素の数に対して、並べ替えを行う場合は、
    計算フィールドより、「count関数」を用いて、システムがデータの個数を
    数えられるように設定する必要があります。

    この記事では、例として、テキスト型のデータ:「名前:姓」データの
    計算フィールドを追加し「姓」の個数に対して、並べ替えを行う方法をご紹介いたします。

    目次

    1. 課題
    2. 原因
    3. 解決策
      3-1.計算フィールドを追加する
      3-2.並べ替えを実施する
    4. 関連コンテンツ

     

    1.課題

    テキスト型データのグラフ内のデータ要素の並べ替えは、
    下記画像のようにデータ名の文字コード順の昇順、降順はできますが、データの数に対しての並べ替えはできません。

    grafdata0.JPG

    図1:「名前:姓」データ
    文字コードに対しての並べ替えイメージ(昇順)

     

     

    2.原因

    テキスト型データは、数値型のデータではないため、テキストの文字コードの並び順で表示されます。

     

    3.解決策

    計算フィールドより、「count関数」を用いて設定することにより、
    システムがテキスト型データの個数をカウントできるようになり、
    下記画像のようにデータの個数順で並べ替えることができるようになります。

    grafdata1.JPG

    図2:「名前:姓」データ
    計算フィールド設定後 並べ替え後イメージ(完成イメージ)

     

    計算フィールドの追加手順と並べ替え手順は以下になります。

    3-1.計算フィールドを追加する

    全キャンペーン(青画面)>[サイドメニュー:レポート]>[グラフ]>[QuickSightから新規登録]

     

    1. 全キャンペーン(青画面)>[サイドメニュー:レポート]>[グラフ]>[QuickSightから新規登録]をクリックします。
    2. 既に登録済みの並べ替えを行いたいグラフをクリックします。
    3. グラフが表示された状態で画面左上の「+追加」をクリックし、「計算フィールドを追加」をクリックします。
    4. 画面右側の「関数を検索」バーに「count」を入力します。
    5. 表示された「count」関数を、ダブルクリックし、画面左側に「count()」を表示させます。
    6. 画面右上の「フィールド」をクリックし、「フィールドを検索」バーに「姓」を入力します。
    7. 表示された「名前:姓」をダブルクリックします。
    8. 画面左側の計算フィールドに「count({名前:姓})」と記載されていることを確認します。
    9. 画面上部の「名前を追加」をクリックし、任意の名前を登録したら、画面右側の[保存]ボタンをクリックします。

      report_1.gif

      図3:計算フィールドを追加する

     

    • 計算フィールドへの関数の記載は手入力でも可能です。
    • 関数のカッコ内()にフィールド内で検索した値を入れます。 
       良い例:count({名前:姓})
       悪い例:count(){名前:姓}

     

     

    3-2.並べ替えを実施する

    全キャンペーン(青画面)>[サイドメニュー:レポート]>[グラフ]>[QuickSightから新規登録]>作成中グラフ

     

    1. 作成中のグラフを表示します。
    2. 画面上部の「フィールドウェル」をクリックします。
    3. 画面左側の「フィールドを検索」バーに、保存した計算フィールド名を入力し検索します。
    4. 「値(緑色)」の欄に、先程保存した計算フィールドをフィールドリストから、ドラッグ&ドロップします。
    5. 「値(緑色)」クリックし、並べ替えのアイコンをクリックします。

      report_2.gif

      図4:並べ替えを実施する

     

    4.関連コンテンツ

    レポート機能で作成したグラフの並べ替えができない

  • レポート機能(QuickSight) では、結合タイプを利用して複数のデータソース間を結合する事ができます。
    結合タイプは、4種類(Inner,Left,Right,Full)あります。
    この記事では、「リードデータ」と「メール送信履歴データ」を結合する場合に、
    各結合のタイプによって表示される結果の違いをデータテーブルを用いて説明いたします。

     

    1.結合タイプ:Inner(内部結合) image3.png

    2つのデータテーブル間で一致するデータのみを表示するには、内部結合を使用します。
    例えば、[リード] テーブルと [メール送信履歴] テーブルで内部結合を実行します。
    この場合、申込者ID、宛先リードIDが一致するデータのみ結果テーブルに表示されます。

    inner.JPG

    図1:結合句:「リード:申込者ID」と「メール送信履歴:宛先リードID」選択時の
    Inner(内部結合)イメージ

     

     

    2.結合タイプ:Left,Right(左と右の外部結合)  

    1つのテーブルのすべてのデータと、別のテーブルの一致する行のみを表示するには左と右の外部結合を使用します。

    ■結合タイプ:left(左外部結合) image1.png

    [リード]テーブル と [メール送信履歴]テーブルに対して左外部結合を実行したとします。
    この場合、すべての[リードデータ]行が返され、[メール送信履歴データ]は、申込者ID、宛先IDが一致する行だけが返されます。一致するデータがない箇所は結果テーブルで空白になります。

    left.JPG

    図2:結合句:「リード:申込者ID」と「メール送信履歴:宛先リードID」選択時
    Left(左外部結合)イメージ

     

    ■結合タイプ:Right(右外部結合) image4.png

    [リード]テーブルと [メール送信履歴]テーブルに対して右外部結合を実行したとします。
    この場合、すべての[メール送信履歴データ]行が返され、[リードデータ]は、申込者ID、宛先IDが一致する行だけが返されます。一致するデータがない箇所は結果テーブルで空白になります。

    right.JPG

    図3:結合句:「リード:申込者ID」と「メール送信履歴:宛先リードID」選択時の
    Right(右外部結合)イメージ



    3.結合タイプ:Full(完全外部結合) image2.png

    2つのテーブル間で一致するデータに加えて、一致しない両方のテーブルのデータを表示するには、完全外部結合を使用します。この結合タイプには、両方のテーブルのすべての行が含まれます。

     

    full.JPG

    図4:結合句:「リード:申込者ID」と「メール送信履歴:宛先リードID」選択時の
    Full(完全外部結合)イメージ



    2.関連コンテンツ

    レポート機能(データセット)結合タイプ(Inner,Left,Right,Full)のデータ処理の違い

  • 1つのレポート内のデータを複数名で同時に編集した場合の挙動について記載します。
    これらの挙動は仕様として定義されていないため、今後変更される可能性があります。

    注意点

    ・この記事は、1つのレポート内のデータを複数アカウントで
     同時に編集した場合の挙動について説明した記事になります。

    ・1つのアカウントを複数人で共有する行為は禁止事項となっております。
     アカウントを共有している場合はこちらをご確認ください。

     

    1. データを複数人で同時編集した場合

    以下の挙動は仕様として定義されていないため、今後通知なく変更される可能性があります。


    1‐1. SMPの挙動


    (例)ダッシュボードにグラフを追加する

    全キャンペーン管理モードの[レポート]タブ > [ダッシュボード]メニュー>[編集]>グラフの追加


    (例)データソースの表示名を変更する

    全キャンペーン管理モードの[レポート]タブ >[データソース]メニュー>[編集]>名前の変更


    SMP管理画面上でデータの編集を行う場合、同時に操作・登録すると、一時的に異なる表示で登録されているように見えますが、サーバーでデータが同期されると、最後に登録を行った内容で表示されるようになります。(あと勝ち)

     

    1‐2. QuickSightの挙動

    (例)グラフを編集する

    全キャンペーン管理モードの[レポート]タブ > [グラフ]メニュー>[編集]>グラフの追加

     

    QuickSight上で同じグラフを同時に操作・登録しようとすると、以下のメッセージと更新ボタンが表示されます。

    保存時の競合 

      「この分析は、別のユーザーによって、または別のタブで変更された可能性があります。新しいバージョンに更新してください。」

     

    FAQ_______2.png

    QuickSightの画面やSMPの管理画面は、それぞれ単一ブラウザで操作を行ってください。

    複数名での同時操作は推奨しておりません。
    同時操作は本記事に記載した挙動以外に想定外の挙動になる可能性がありますのでご利用はお控えください。



    2.関連コンテンツ

    レポート機能で1つのデータを複数人で同時編集した場合の挙動