リード基本項目の項目間依存(申込者基本項目の項目間依存)やデザインカスタマイズの影響で、
入力が必須のリード基本項目(申込者基本項目)がフォームに表示されていない可能性があります。
1. 原因
考えられる原因は2つあります。
- デザインテンプレートカスタマイズの影響
- リード基本項目の項目間依存(申込者基本項目の項目間依存)の影響
1-1.デザインテンプレートカスタマイズの影響
リード基本項目設定(申込者基本項目設定)で「表示/非表示」を「表示」かつ「必須」に設定している項目に対し、CSSやJavaScriptを利用して、デザイン上非表示にしている場合に事象が発生します。
必須項目が未入力とシステムが判定し、確認画面に進めない状態になります。
デザイン上フォームに項目を表示されないため、必須エラーは表示されません。
1-2.リード基本項目の項目間依存(申込者基本項目の項目間依存)の影響
リード基本項目の項目間依存(申込者基本項目の項目間依存)を設定している項目のうち、先頭に表示される項目の「表示/非表示」が「管理者のみ表示」になっており、2つ目以降に表示される項目の入力が「必須」になっていた場合に事象が発生します。
リード基本項目の項目間依存(申込者基本項目の項目間依存)を設定している先頭の項目が「管理者のみ表示」になっている場合、依存設定をしている他の項目も非表示となりますが、2つ目以降に表示される項目の「必須」制御は行われるため、確認画面に進めない状態になります。
フォームに項目が表示されないため、必須エラーは表示されません。
2. 対策
対策は下記2点です。
- リード基本項目設定(申込者基本項目設定)で各項目の「必須」の設定を確認する
- リード基本項目の項目間依存(申込者基本項目の項目間依存)設定を行っている項目を確認する
2-1.リード基本項目設定(申込者基本項目設定)で各項目の「必須」の設定を確認する
デザインテンプレートカスタマイズの影響で、事象が起こっている場合に有効な対処方法です。
- 全キャンペーン(セミナー)もしくは個別キャンペーン(セミナー)管理モード>サイドメニュー[リード(申込者)]>サイドメニュー[基本項目]をクリックします。
- 「表示/非表示」が「表示」になっている項目で、申込フォームに表示されていない項目がないか確認します。
- 該当する項目があった場合「必須」の列にチェックマークが付いているか確認します。
- チェックマークが付いている場合、項目の[編集]リンクをクリックし、「必須の可否」を「必須にしない」に変更後、[登録]ボタンをクリックします。
- 申込フォームですべての必須項目に入力後遷移ボタンをクリックし、確認画面に進めるか確認します。
上記方法を行っても改善されない場合は、以下の方法を確認します。
2-2.リード基本項目の項目間依存(申込者基本項目の項目間依存)設定を行っている項目を確認する
リード基本項目の項目間依存(申込者基本項目の項目間依存)設定の影響で、事象が起こっている場合に有効な対処方法です。
- 全キャンペーン(セミナー)もしくは個別キャンペーン(セミナー)管理モード>サイドメニュー[リード(申込者)]>サイドメニュー[基本項目]をクリックします。
- リード基本項目の項目間依存(申込者基本項目の項目間依存)を設定している項目の「表示/非表示」が全て「表示/非表示」が「管理者側のみ表示」どちらかの値で統一されているか確認します。
- 統一されていない場合、「表示/非表示」が「表示」になっている項目の[編集]リンクをクリックし、「表示/非表示」を変更後、[登録]ボタンをクリックします。
- 申込フォームですべての必須項目に入力後遷移ボタンをクリックし、確認画面に進めるか確認します。
3. 関連マニュアル
今回の記事に関する以下のマニュアルも合わせてご利用ください。
4. 関連FAQ
今回の記事に関する以下のFAQも合わせてご利用ください。